Transmit Data to pmu connection tester through networking


The AlarmLog table is in the database, and you will need to use database tools to query it. For instance, with a SQL Server database, you can use SQL Server Management Studio or sqlcmd to query the AlarmLog table.

In the PMU Connection Tester, you have filled in the TCP tab without defining an alternate command channel. This implies that you intend to transmit all frames over a single TCP communications channel. When you created your output stream, if you specified both a TCP Channel and a UDP Channel, then the openPDC will be expecting to transmit command frames and configuration frames over the TCP channel and data frames over the UDP channel. In that case, if you don’t configure the PMU Connection Tester to listen for data over the UDP channel, it won’t receive any data frames.



I tried to concentrate my output stream by using both channels. I am sending you screen shots of my work.

Please check and tell me suggestions what can i do to accomplish my task?


PMU Connection Tester is forcing IPv4 so you will also need to force IPv4 in the openPDC for that to work. Otherwise, ‘localhost’ in the UDP channel will resolve to an IPv6 address and stream the data to the wrong endpoint.

TCP Channel: Port=8900; Interface=
UDP Channel: Port=-1; Clients=localhost:4712; Interface=



I have tried your suggestion but it gives me same result.
My output data stream is not running .

What can i do now sir?


After changing the TCP and UDP channel settings, you need to make sure to both Save and Initialize your output stream, in that order.


I have saved and initialized but it doesn’t work.


I just noticed you have multicast/remote UDP enabled in the PMU Connection Tester. Try unchecking the box that says “Enable Multicast / Remote Udp”. That feature will not work when using “Port=-1” for the openPDC UDP channel.


I have tried by unchecking the box of “Enable Multicast / Remote Udp”.

It’s not working sir.


I don’t know what else to tell you. The same exact setup works fine for me.

Are you running openPDC and PMU Connection Tester on the same system?



yes sir
I am running open pdc and pmu connection tester on same system.
What can be the problem sir? Please help me


Either the data is not streaming from the source device or the openPDC is not streaming data to localhost:4712. Beyond that, I’m not sure what could be wrong.



Sir what will i do now?
Why open pdc is not streaming or data is not streaming from the source ? What can be the reason? Please help me ! This is important part of my project.


Start investigating. You have to figure out why your data isn’t streaming. For instance, does the data show up on the Graph Measurements screen in the openPDC Manager? Can you maybe do away with the UDP channel in openPDC and use the TCP channel for data?


Yes sir ! Data is shown on graph measurement screen.
I can’t understand what you say about tcp and udp? Please guide me!


Steven is saying you can simplify your connection by only using TCP and not using UDP. In this case only fill out information in the openPDC Manager for TCP - the UDP settings should be blank. In the PMU Connection Tester, you should also only be on the TCP tab - with no alternate command channel defined. Also, always make sure to “re-initialize” your output stream after any configuration changes so the changes will take effect.

This is the simplest possible connection.

Now, if you still have no data, then the timestamps in your data are being discarded. Cause being that the timestamps are outside of range of the local clock according to your lead-time setting. To completely ignore bad timestamps you can unselect the “Perform Timestamp Reasonability Check”.

If you still see no data - make sure you can actually see data in the openPDC Manager under “Graph Measurements”…



By the way, as a courtesy to those are trying to help you, it is considered not polite to end your sentences with an exclamation point. When read, statements ending with an exclamation point are generally considered as yelling and/or demanding and over all considered rude. I assume English is not your first language so we have been ignoring your punctuation and emphasis, but I assure you, it is not required to get a more timely response. As with any one who posts a question, we will answer as quickly as we can given all our other duties.

Thanks so much and good luck with your project…


I apologise ritchie and steven sir for my bad english. I haven’t meant to yell or demand. I am only requesting and you helped me alot in this project and i am greatful to you. Sorry sir


I have tried this before. I only filled tcp tab without alternate channel. But results are same. I uncheck reasonability check option but data is not streaming.


Try removing the connection string under “UDP Channel” in the openPDC Manager. Remember to Save and Initialize the output stream, in that order.



I have done same to same thing as you say but results are same.