How to set the figure, when we want Openpdc output

I use OpenPDC to read a CSV file successfully.

Now, I cannot use the OpenPDC to output the data.In home page, I can see nothing and In PMU connection tester, I also can see nothing.

I am not sure where I make mistakes. Could you help me?
Thanks a lot.And here is my output stream setting.

In PMU Connection Tester, it seems you have defined an alternate command channel, but the output stream only has the one TCP channel. Try removing the alternate command channel configuration.

Also, there is a mismatch between the output protocol and the input protocol. Try selecting IEEE C37.118-2005 in PMU Connection Tester.

Dear Stephen,
I follow your instruction to set the figure. However, the PMU connection tester are still not receive the data.I am not sure where the mistakes occurs?

You still have an alternate command channel defined. You must undefine your alternate command channel in the PMU Connection Tester configuration.

I do not define the UDP channel. But the PMU connection tester still cannot receive data.

And also I can use these code to receive the shelby sample, which is in the OpenPDC.
However, I cannot receive my sample. And my sample is a csv file, which was read by OpenPDC.

Run PMU Connection Tester on the same system as you run openPDC. Use the TCP tab to define a single TCP channel for Do not define an alternate command channel. Based on your output stream configuration, that’s all you should need.

If it’s still not working after getting the PMU Connection Tester configuration right, then it’s probably an issue with the output stream. Have you defined any output stream measurements?

This is my output stream measurements. I am not sure whether it is right?

Do you have some example? I can follow this to make sure everything in my openpdc is right.

Your signal references are incorrect. They need to follow a DEVICE-ST# syntax so the output stream adapter can determine how to map them into the IEEE C37.118 data frames.

The most appropriate guide is probably this one, although it might be a bit out of date.

The signal references comes from the setting of input measurement. You mean that I need to change the name of the input measurement?

It might be wise to update the signal references of your input measurements for various reasons. However, the output measurement has its own signal reference that it uses for IEEE C37.118 mapping.

Thanks a lot. Stephen
This is a picture that my partner sends to me. I want to check whether the Signal Reference in this picture is right.

Because I think it is not conform to DEVICE-ST# syntax.

If that measurement were associated with an IEEE C37.118 stream, that signal reference would indeed be incorrect. Even apart from the IEEE C37.118 context, some of the visualization tools are better able to determine useful characteristics of the data by parsing the signal reference. Therefore, I would use PMU_A-PM1 based on…

Device: PMU_A
Signal Type: Phasor Magnitude (PM)
Phasor Index: 1

I correct the signal reference. However, we still cannot connect to the PMU connection tester.

Well, I set one up as close as I could to your configuration. I am using the SHELBY sample data, but I am able to receive data frames in PMU Connection Tester.

Here’s a handful of things to check.

  • Ensure that you initialized the output stream after changing output stream measurement configuration
  • Ensure that the input data is still being received on the Graph Measurements page
  • I assume this data is still coming from a CSV file; ensure that the connection string for the CSV Input Adapter is simulating timestamps
  • Use the Graph Measurements page to verify that your input measurements’ timestamps match up with the openPDC’s local clock
  • Use the list TESTSTREAM command on the openPDC Console and check the following metrics:
    • Received measurements
    • Processed measurements
    • Discarded measurements
    • Down-sampled measurements
    • Published measurements

Dear stephen,
Thanks for your patience. I see that there is no waveform in your PMU connection tester. I am not sure whether we only can receive data frames but cannot have waveform like that in graph monitoring in OpenPDC we see. And Could you give me a link to download shelby sample data in csv file? I am not sure my csv file in right form.
Thanks again

Dear stephen,
Thanks for your patience. I follow your instruction to use OpenPDC Console to find my OpenPDC cannot load cached configuration because it do not have a xml file. I do not know how to generate a xml file by OpenPDC. Thanks for your help.

I was under the impression you were getting data from a CSV file. Is EVENT_1 a real PMU?

No, EVENT_1 is a csv file. It is not a real PMU.
Yes, I am getting data from a csv file.