Web Interface Login Help

After installing openHistorian, the utility opens a locally hosted web page asking for credentials. No matter what I type in I always get a red box at the bottom stating: “No access available for “null” using pass-through authentication” if I have use integrated windows authentication or “Login attempt failed: Internal Server Error (500)” if I use my MySQL database username and password.

What credentials is this page asking for exactly?

When setting up the openHistorian with the Configuration Setup Utility during installation, one of the screens asked you to set up the admin account. Assuming you left everything on that page alone and used the defaults, it will have set up the system to use the Windows account of the user that was logged into the system during installation. That would most likely be your Windows account.

The issue you’re having is likely with the Edge browser, which does not allow integrated Windows authentication for pages hosted on the loopback interface. You can enter your Windows credentials (DOMAIN\user and the corresponding password) with NTLM authentication or use a different browser with integrated Windows authentication.

Alternatively, and I just found out about this so we haven’t tested it, but it looks like they did implement a workaround for Edge by enabling the user to configure an intranet app container in Edge to include the loopback interface. You can see more details in the comments of the following webpage.

So log-in still fails with integrated authentication and NTLM using the domain\user & password in IE11, Chrome, and Firefox.

I used the configuration setup utility to set up a new configuration and this time used the Database Authentication method where I entered my own username, password, first name & last name. Now I get “Login attempt failed: Internal Server Error (500)” with every attempt on IE11, Chrome, and Firefox.

Next I tried using the same username & password in IE11 running it with administrator privileges. This resulted in the same internal server error.

Next I opened openHistorian Console and tried to login there.
Enter password:
Connecting to tcp://localhost:8510…

Exception during connection attempt: A connection attempt failed because the con
nected party did not properly respond after a period of time, or established con
nection failed because connected host has failed to respond

Disconnected from tcp://localhost:8510:

              Client state: Disconnected
           Connection time: 33 seconds
            Receive buffer: 8192
        Transport protocol: Tcp
        Text encoding used: US-ASCII

Connection was terminated before completing authentication.

Connecting to tcp://localhost:8510...

Connected to tcp://localhost:8510:

              Client state: Connected
           Connection time: less than 1 second
            Receive buffer: 8192
        Transport protocol: Tcp
        Text encoding used: US-ASCII

Exception during connection attempt: Unable to authenticate connection to server
: Cannot access a disposed object.
Object name: 'SslStream'.

Disconnected from tcp://localhost:8510:

              Client state: Disconnected
           Connection time: less than 1 second
            Receive buffer: 8192
        Transport protocol: Tcp
        Text encoding used: US-ASCII

Connection to the service was rejected due to authentication failure.
Enter the credentials to be used for authentication with the service.

Enter user name:

Next I tried to open the openHistorian manager, I get the splash screen, then a error in a dialog box that looks like Java but it opens and closes too fast for me to read.

It looks like your system is not working at all. You said you are using a MySQL database, right? What version of MySQL Connector/NET are you using? We’ve identified numerous issues when using the latest version (8.0.11) as well as the latest previously GA release (6.10.7). We recommend using version 6.9.12 with our products.

It looks like I am using MySQL Server 5.7.20-log & MySQL Connector version 6.10.5 so that could be it. The database test connection in the setup works correctly so I know it can contact the database, write tables, etc. I can see it created ~47 tables during install.

I will start working on changing versions.


Uninstalling MySQL Connector/NET 6.10.5 and installing 6.9.12 coupled with a reboot has fixed the log-in issue.

Hi @StephenCWills,
The official download page does not have the 6.9.12 version. Can you suggest a valid source to get this version?

Hi Itan,

The 6.9.12 version used to be available as an option under generally available releases. The link for the download may still be active, but it seems that Oracle has changed their webpage a bit so I am no longer able to navigate to it. The 6.9.11 version should work just fine too so that’s the best one I can recommend at this point.