Verifying IEEE-C37-118 slave communication using pmu connection tester

Hi, I am Usama, I am trying to see my PMU data using PMU connection tester. I am using OPAL-RT simulator in real time, which is sending the data through PMUs. My model is running perfectly fine in the simulator but when I try to establish connection between OPAL-RT and PMU tester using same ip address, it says that

Can anyone please help me that what is actually happening.


This error message indicates a WSAECONNREFUSED socket error occurred as a result of a TCP connection attempt.

This error typically occurs during the TCP handshake. When the PMU Connection Tester sends the first SYN packet, the remote system responds with an RST packet indicating that there are no applications listening on the specified port. The issue is most likely caused by one of the following:

  1. Incorrect TCP port - the application you are trying to connect to is listening on a different port than the one you entered into the PMU Connection Tester.
  2. Incorrect IP address - the IP address or host name you entered has caused the PMU Connection Tester to connect to a different system than the one you meant to connect to.
  3. Alternate command channel - there is a link on the far right under the “Connect” button that allows you to configure a separate communications channel over which you can issue commands to the PMU. Since you are using simulated data, your PMUs probably do not accept commands. You will most likely want to turn the alternate command channel off.


Hi Stephen,

Thanks for your reply. I have checked all the three steps and there is nothing wrong on my end. Here is the screenshot of the IP address, port number, device id and comm protocol which are exactly matching to my real time simulator.

The funny thing is that it was working fine last time but it is giving me this error now.

Is the PMU Connection Tester running on the same system as OPAL-RT? Does the simulator create a separate IP address for the PMU, or is it the same as the system it’s running on? Maybe there is another system on your network with the same IP address. It may help to select a specific network interface using the link below the Port text box.

Were you doing anything differently when it was working fine the last time?


I tried PMU tester on the same system and on the different system as well. The simulator IP address is different than the IP address of the system on which it is running. No other system on my network has the same ip address and I was not doing anything different last time when it was working fine.

I do not know what is wrong. I am really confused now and what do you mean by this:

It may help to select a specific network interface using the link below the Port text box.

In your screenshot, there is some blue text under the Port text box that says “Network Interface”. That blue text is a link you can click on to change the network interface used when communicating over the network. For instance, if there was a system on your network that has the same IP address as the simulated PMU and is connected to your physical network card, you can select the virtual network interface that is connected to the simulated PMU so that the PMU Connection Tester’s IP packets cannot possibly reach the other computer.

There are two things I can infer by the error message you are getting:

  1. The PMU Connection Tester’s IP packets are definitely reaching a device somewhere on your network.
  2. The device receiving the packets is not listening on the TCP endpoint.

If you insist that your packets cannot possibly be reaching any other device on your network, then the PMU itself must not be listening on the TCP endpoint. I don’t know how the OPAL-RT simulator works, but there are two things that would help immensely if you are able to do them.

  1. Run netstat on the simulated PMU to see whether the device thinks it is, in fact, listening on the TCP endpoint.
  2. Run a packet capture on the simulated PMU to see whether the PMU Connection Tester’s IP packets are, in fact, reaching the PMU and not some other system on your network.

Hi Stephen, I can understand what you are trying to say but pardon me if I ask some rudimentary questions:

  1. How can I run on the simulated PMU?

  2. How can I run packet capture on the simulated PMU?

Will appreciate your help.

Well, like I said before, I don’t know how OPAL-RT works. For all I know, it may not even be possible to run netstat or a packet capture on the PMU. Here are a couple links to general information about netstat and Wireshark.

Hi Stephen, I am able to see the data on my PMU connection tester as you can see below:

Now I want to see this data on open PDC manager. When I open the open PDC manger as you can see from fig,

and I press request configuration, it is giving me the following error. Do you know what maybe the reason for that.

Go back to step one and remove the quotes from the connection string.