Tons of the same exception. What should I do next?

I got tons of the same exception in the log. Please help.

Time: 4/14/2021 12:08:47 AM - Component - NA - SystemHealth - None
Event Name: First Chance App Domain Exception
System.UnauthorizedAccessException: Access to the path ‘CompiledRazorTemplates.Dynamic.RazorEngine_c1571f05d7d34ec897535e2f89d3a77a.dll’ is denied.
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
Message Type: GSF.Diagnostics.Logger
Message Assembly: GSF.Core.dll (2.3.300.0)
Managed Thread Id: 1

Current Stack Trace:
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath) IL offset: 435
at System.IO.Directory.DeleteHelper(String fullPath, String userPath, Boolean recursive, Boolean throwOnTopLevelDirectoryNotFound, WIN32_FIND_DATA& data) IL offset: 544
at System.IO.Directory.Delete(String fullPath, String userPath, Boolean recursive, Boolean checkHost) IL offset: 219
at GSF.TimeSeries.ServiceClientBase.Start(String[] args) IL offset: 1516
at openHistorian.Program.Main(String[] args) IL offset: 145

What version are you using? Have you tried nightly build?

Hello, thank you so much for your reply.

I do not see a place that could tell me the built info. I downloaded the source code from github and built it from there. I am more interested in how to debug this thing. Right now I do not know where should I start.

simple question, what is “CompiledRazorTemplates.Dynamic.RazorEngine_c1571f05d7d34ec897535e2f89d3a77a.dll” ?

In general, it seems a good application, but few thing I noticed:

  1. the OPC ua adapter seems not working. (or I can’t get it to work). I got this adapter from GIthub.

  2. the log utility does not pull the log info automatically. not automatically pulling info seems weird to me. I have to reload the log file every time.

The CompiledRazorTemplates.Dynamic.RazorEngine_*.dll files are simply compiled instances of the web pages openHistorian uses.These are unrelated to OPC.

  1. This is a third party adapter that is not automatically included with the openHistorian, your best bet for assistance on this adapter is to post an issue on the author’s GitHub page
  2. Can you provide more details about which log tool you are using that is giving you trouble?


ok. thanks for reply. maybe i should get to my first issue. the OPC UA adapter never worked in my PC. what info should i provide for someone helping me? thanks.

or the question is even simpler, how can i debug the OPC UA adapter?

Have you checked this thread? It may help: