Timetag stuck in the current data web service

Hi all.

I have noticed that the timetag in the current data web service is stuck at “1995-01-01 00:00:00”:

I captured this snapshot some minutes ago (03/21/2017-15:23:37 UTC) from our openPDC. The measurement is a frequency (60 Hz nominal) from a PMU, running in real time.

It is happening in version 2.3.4, and in the new version 2.4.120 too. We have another one, v2.1.120, receiving the same PMU data, and there the timetag is ok.

Does anyone know somethig about this behavior? Is there some additional configuration in the new openPDC versions (2.3.4 and 2.4.120) for this?



I have the same problem with the latest version.

Thank you and BR.

I just posted the issue to the GSF project on GitHub.

I simultaneously committed a fix for the issue so this should be resolved in the next nightly build (openPDC v2.4.124).

FYI - we are working on a patch that can be applied to the openPDC 2.4 official release so you won’t have to install a nightly build…

We have posted a new download in the openPDC v2.4 release. You can go there to download the patch. The file is called OH1.0-time-series-web-service-fix.zip.

Here are the instructions to apply the patch:

  1. Download the zip file.
  2. You may need to go to Properties on the zip file and click the Unblock button. If you do not see an Unblock button, then you do not need to do this.
  3. Extract the zip file.
  4. Stop the openPDC service.
  5. Replace GSF.Historian.dll in the openPDC installation directory (C:\Program Files\openPDC by default) with the one you extracted in step 3.
  6. Start the openPDC service.

Thanks guys! I’ll try the patch at night here in Brazil (about 23:00 UTC), and I let you know.

Guys, I did the previous procedure, but unfortunatly the web service stoped working when I tried to use the new “GSF.Historian.dll”. Now I’m getting a refused connection error (ERR_CONNECTION_REFUSED) when I try to access the web service.

Any idea?!?!

Connection refused means it’s not listening on the port. There may have been an error loading GSF.Historian.dll. Check the error log.

Windows operating systems these days will flag files that come from network locations. The .NET Framework will block the openPDC from loading assemblies that came from network locations. Did you make sure to unblock the zip file before extracting the dll (step 2)? You may also try unblocking the dll itself.

Seems unrelated to change. Perhaps a reboot?

Also, you may need to delete ppa_state.dat and stat_state.dat file…

We did some additional testing and managed to reproduce the behavior you described. Turns out it was an issue with the patch, and we were able to resolve it. We’ve updated the GitHub site with the fixed patch, so if you download the patch again and follow the steps to apply it, the historian web services should start working again.

1 Like

Guys, it is working great now! Just for the records, I followed the instructions again now, with the new patch, and it worked. No reboot nor historian file deletion were necessary. I´ll reproduce the solution in our production openPDC.

Many thanks for your fast response. Please let us know if we can help you with any other tests here in the MedFasee Project, at this side of the globe.