Subscriptions on different pc's?


#1

Hi all,
I have managed to get OpenHistorian to subscribe to a OpenPDC on the same machine with no issues. I can see all of OpenPDC’s inputs live on the OpenHistorian graph measurement screen.

My issue is when I try to subscribe to a OpenPDC on another PC. After a bit of fumbling around, I assume you pick the option
Manage Authorized Subscribers
image
but when saving I get this error.
image

A bit more fumbling around and I figured on the subscribing machine I have to
Create Authorization Request
which I fill in with
image
I then import the file this creates by choosing
Import SRQ on the Manage Authorized Subscribers form
on the machine the data is originating from.

I still can’t get subscriptions working at all. I figure I have to modify
Manage Subscriber Measurement Access

image
Finally, after trying to view a shelby on OpenPDC on 1 machine to a OpenHistorian on another machine, nothing happens. I don’t see any errors in the console window.

Any ideas what is missing?


#2

You’re pretty close. The last step is to go back to openHistorian Manager and subscribe to measurements using the Inputs > Subscription Based Inputs > Measurement Subscriptions page. If you don’t see the measurements from the openPDC, you may need to go to Inputs > Browse Input Devices, then select the PC2 device and Initialize it.

That said, it’s actually a little bit unusual to use authorized subscriptions between the openPDC and openHistorian. That process was designed for creating secure channels over unsecure networks, such as the internet, as you might do with an installation of SIEGate positioned at the edge of your internal network. An easier way to subscribe would be to use the Inputs > Subscription Based Inputs > Create Internal Subscription page using the openHistorian Manager. This would allow you to set up a simple connection to openPDC that will automatically receive data without any need for explicit authorization within the openPDC Manager.

Either way you do this, you may encounter issues due to firewall restrictions. If you proceed with your current setup, you will need to allow incoming connections on port 6167 through the firewall on the openPDC system. If you switch to an internal subscription instead, you should allow incoming connections on port 6165, also through the firewall on the openPDC system.


#3

Thanks Stephen.
I’ll let you know how I go.

What I am trying now is a proof of concept just within our network. The end goal is to try and see if a OpenHistorian in the cloud is able to subscribe to an openPDC behind a firewall that will be secure out over the internet, plus to give the benefit of the data recovery features built into these products if the internet goes down for any reason.


#4

I can’t get the input device to show up in the measurement group form.
I can see the openHistorian and openPDC are connected from the console messages and from this. I have tried initializing a number of times.

image

On the OpenPDC i can see messages about receiving requests and sending replies on the console… but im guessing like nothing is arriving?
Ive opened all ports for openhistorian.exe and openhistorianmanager.exe for testing purposes.

On the historian side, pc2 looks dead

image

Any idea what is missing?


#5

I don’t suppose you noticed any errors when monitoring the console while the openHistorian was initially connecting to the openPDC? Normally, I’d expect PC2 to have a child device if metadata synchronization completed successfully.


#6

On the publishing machine I get this in the status log

[1/31/2019 3:50:26 PM] [EXTERNAL!DATAPUBLISHER] Client connected to command channel.


[1/31/2019 3:50:26 PM] [EXTERNAL!DATAPUBLISHER] Registered subscriber "NOJA Subscription Authorization" noja-180.nojapower.local ([::ffff:10.10.150.87]:54504) was successfully authenticated.


[1/31/2019 3:50:26 PM] [EXTERNAL!DATAPUBLISHER] Received meta-data refresh request from noja-180.nojapower.local ([::ffff:10.10.150.87]:54504), preparing response...


[1/31/2019 3:50:26 PM] [EXTERNAL!DATAPUBLISHER] 28 records spanning 4 tables of meta-data prepared in 36.99 milliseconds, sending response to noja-180.nojapower.local ([::ffff:10.10.150.87]:54504)...


On the subscribing machine I get this

[1/30/2019 4:27:58 PM] INITIALIZE:Success(22) - Adapter "PC2" (22) was successfully initialized...
[1/30/2019 4:27:58 PM] [PC2] Data subscriber command channel connection to publisher was terminated.


[1/30/2019 4:27:58 PM] [PC2] Disposed.

....
....
....

[1/30/2019 4:28:02 PM] [PC2] Attempting connection to tcp://10.10.150.84:6167...


[1/30/2019 4:28:02 PM] [PC2] Attempting command channel connection to publisher...


[1/30/2019 4:28:02 PM] [PC2] Connection established.


[1/30/2019 4:28:02 PM] [PC2] Data subscriber command channel connection to publisher was established.


[1/30/2019 4:28:02 PM] [PC2] Success code received in response to server command "Authenticate": Registered subscriber "NOJA Subscription Authorization" noja-180.nojapower.local ([::ffff:10.10.150.87]:61317) was successfully authenticated.


[1/30/2019 4:28:02 PM] [PC2] Success code received in response to server command "MetaDataRefresh": latest meta-data received.


[1/30/2019 4:28:02 PM] [PC2] Received a total of 28 records spanning 4 tables of meta-data that was uncompressed and deserialized in less than 1 millisecond...


[1/30/2019 4:28:02 PM] [PC2] Meta-data synchronization is 19.4% complete...


[1/30/2019 4:28:02 PM] [PC2] Meta-data synchronization is 38.7% complete...


[1/30/2019 4:28:02 PM] [PC2] Meta-data synchronization is 58.1% complete...


[1/30/2019 4:28:02 PM] [PC2] Meta-data synchronization is 77.4% complete...


[1/30/2019 4:28:02 PM] [PC2] Meta-data synchronization completed successfully in 5.98 milliseconds

I am only testing this with the built-in openHistorian TESTDEVICE. Does that make a difference?
Is there some other configuration required? I saw a Measurement option under Metadata which i haven’t touched yet.


#7

I don’t think TESTDEVICE should make any difference. The configuration you need is just the metadata that was synchronized when PC2 connected. It looks like metadata synchronization worked so PC2 should already have some child devices. In openHistorian Manager, if you look at Inputs > Browse Device Inputs, do you see a device called PC2!SHELBY? Also, if you go to Inputs > Subscription Based Inputs > Measurement Subscriptions, do you see a list of measurements available for subscription?


#8

Hi.
No I don’t see any devices on PC2 when I pick Browse Device Inputs, and also Measurement Subscriptions is blank and nothing available to choose from the top right drop down list. And also no errors in the log file.
I did test an internal subscription with 2 OpenHistorians on the same machine and that does work correctly. I am able to see the devices from the other historian and also view its measurements.

Out of frustration, I have tried the TLS route of Authorized subscriptions which I am also having trouble to get working. I have made a new topic for that one so as not to mix up the 2!


#9

Ohh, I didn’t notice that you had chosen the Gateway security mode. Honestly, the Gateway security mode has been deprecated, and it hasn’t been tested in a very long time. TLS is the recommended security mode for setting up gateway authorizations. For now, I will head over to the other topic to help you out there instead.


#10

No worries. Thanks for letting me know I wasn’t going insane.