Storing the same input device data in two historians

I have successfully created an input device and stored its measurements in a local historian. I am trying to store the same data in a remote OSI PI historian.

I’ve created a PI historian instance. Then, I created a new measurement for the PI historian that uses the same signal reference as the measurement being stored locally. But under “Monitor Device Outputs”, the PI measurements all show “0” for their data.

What am I doing wrong and is there a better way to accomplish this?

The OSI-PI adapter will automatically synchronize metadata. When configured properly, data and metadata should flow into PI.

See the following:

Hi Ritchie, thanks for responding.

The tags I created were populated in the PI server but the issue is that I can’t seem to reference the data in the measurement.

I wanted to store this tag in both the PPA local historian and my PI server:

So I created a new measurement using the same signal reference.

But when I went to check the output, the measurement does not seem to receive data, it just lists “N/A” for time. The tag is created in the PI server.

Is the signal reference not what I should be using?

If a measurement exists - it will go to all configured destinations, e.g., local PPA historian and OSI-PI - you do not need to create a separate measurement.

The measurement signal ID should be unique in the universe of measurements…

Check your OSI-PI connection string, make sure it contains something like ; sourceIDs=PPA - this will make sure all measurements associated with the local historian PPA also get pushed to PI.

If you update the connection string, be sure to save the adapter record and re-initialize it…


Hi Ritchie,

I tried “sourceIDs=PPA” on the historian instance but it did not seem to have an effect. When I ran the “list” command in the console it still showed the source ID as “PI” (my acronym). Is this expected?

However, using InputMeasurementKeys in the connection string did change the values stored.

Hi Ritchie

I found this tread and tried to setup an OSI-Soft connected using openPDC V2.7. However when I got to select the Primary History, the OSI-SOft connector is not an option.

Does the SDK need to be isntalled before OpenPDC is installed to have the historian as an option? or has this option been removed in V2.7?


It does - you have to install the OSI-PI SDK before the adapter can be loaded - otherwise it’s invisible, i.e., not shown.

1 Like

Hi Ritchie,

Thanks for sharing these very useful resources. I’m trying to archive/stream data from my openHistorian system to the PI system. Could you kindly indicate whether openHistorian 2.6.30 might also include the OSI-PI adapter? If so, is there any documentation on which version of the PI system it’s compatible with?

At the moment, the OSI-PI adapter is not showing up as an option in my configuration utility like in the Archiving data to the OSI-PI Historian using the openPDC video. Do I need to install the OSIsoft AF SDK first to get this to show up?


This adapter is automatically included, however, it will only be visible if the OSIsoft AF SDK is installed on the same system as the openHistorian service.