PMU connection Tester receives junk chars from PMU

Hi Ritchie,

I have connected a PMU from one laptop (running Windows 10 - English), please see the output.

  1. PMU connection Tester was successfully connected with PMU.
  2. Received initial configuration frame.

But, Data frame looks like junk chars. Due to this, from openHistorian, was not able to read the values.

Could you please help on this?


Hi Logu,

The “Display” selection is set to “ASCII Extraction”

Hi Ritchie,

Thanks for your information.

Actually, PMU is sending data and able to see same data in PMU connection tester.
But openHistorian is not showing any data and no error in error log.
Also I’m able to see the packets in wireshark.

I saw some error in error log “index out of bound” then I uninstalled openHistorian and re-installed the same, but still same behaviour but no error log is generated.

UDP port is listening at PDC machine.
If you could throw lights, that would be helpful.


With a UDP port, you cannot run an active PMU Connection Tester and openHistorian on the same machine. Only one application can listen on a UDP port at once.

Hi Ritchie,

We are not running both Connection Tester and openHistorian at the time.

See the below log:

[5/18/2021 4:42:44 PM] [STATION_A] Connection established.
[5/18/2021 4:42:44 PM] [STATION_A] Statistics reset for all devices associated with this connection.
[5/18/2021 4:42:44 PM] [STATION_A] Received initial configuration frame at 5/18/2021 6:42:44 AM
[5/18/2021 4:43:24 PM] [STATION_A] No data received in 15.0 seconds, restarting connect cycle…
[5/18/2021 4:43:24 PM] [STATION_A] Disconnected from tcp://…:…

Sametime, wire shark shows data arrival to UDP port.

Try adding interface= to the connection string for an IPv4 stream.

If that doesn’t work, we can try a WebEx/zoom/teams type call to diagnose in a couple of hours.

I tried that also, but still not working. However I will try again and come back to you with WebEx details.

Just send me an email for a WebEx for 10:30pm US Central time if that time allows you a lunch break, can go later too.


Hi Ritchie,

Currently the person, who is facing problem is not available and I will check the settings once again and still not working then we will plan for Teams meeting.

Thanks & Regards