openPDC UDP data loss on output stream


#1

Hi,

I have PMUs streaming at 120fps and created output streams for them. They work fine, except for the fact they’re streaming at 118fps instead. I am losing two phasors every second, in the same fractions of second (0.208333 and 0.808333). I have checked on Wireshark and verified these two phasors are never sent from openPDC.

I have already tried to change lag time (intially it was set as 3, I changed it up to 60) and saw no changes. When I change the output stream to 60fps, these losses are non-existent. Any clues to why that may be happening and how I can fix it?

Thanks in advance,

Juliana.


#2

I assume, since you are using Wireshark, that you are inspecting the frames from an output stream you configured within the openPDC. Most likely, the concentrator in that output stream is downsampling those two data points into another frame due to arithmetic and/or truncation errors in the timestamp. In any case, I would recommend marking the Round to Nearest Timestamp checkbox under Advanced Properties on your output stream configuration.


#3

Jut checked it and it worked!

Thanks for your help! :slight_smile: