openPDC and historian on linux

Hi all, I’m working on a project that includes running openPDC in a distribuited environment. Specifically we want to run openPDC in Linux instances, using MySQL as DBMS, and access this remote environment with an openPDC Manager installed in a windows machine for configuration and monitoring.

I’ve found a couple of issues during the installation and configuration phase, I thought was better to write everything in a single topic but if you think it would be better to split it into different topics or open issues on github I will do so.

I followed the guide for installing openPDC in posix environments but the latest available version of the installation script (taken from here) tries to install the 2.5 version, in which fails the build of the gsf dependency and with that the whole installation. (gsf failing build log)

Editing the openPDC version in the script from 2.5 to 2.4 the build is successful and the script runs smoothly, although showing an error on copying the folder related to the web service “wwwdata” that I understand was added in version 2.5.

As a starter configuration I used the one provided in the zip in order to configure also the included historian and correctly connected a dumb PMU simulator (previously tested with the PMU connection tester to make sure it worked).

From the Manager I could not really configure the connection, I could add the configuration to the database using the UI but I needed to manually reload the configuration from the openPDC console since the Manager tried to connect to the local openPDC service instead of the remote one.

Again from the Manager I see the red light on the top right corner, I guess as earlier it tries to connect to a local service that is not running and so gives a “bad” feedback. From the manager I can see the list of inputs (my PMU simulator) but cannot see any data/phasor/measurement in real time, the graph is empty.

On the openPDC side, the included historian is not running since the open ports are just:

/opt/openPDC # netstat -ltu
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State
tcp        0      0  *               LISTEN
tcp        0      0  *               LISTEN
tcp        0      0  *               LISTEN
tcp        0      0  *               LISTEN

I have also thought about installing the latest version of openPDC but the 2.9 too obviously requires the gsf dependency and the build with mono fails.
The same problem occurs with openHistorian 2.5 and 2.4, that I thought to run instead of the one included with openPCD.

I know that both openPDC and the manager 2.4/2.5 are not the latest version and you are currently putting your efforts on newer versions but it would be great if you could give me some help making this setup work.
I’m open to any suggestion and available to give more detail about the issues.

The linux setup is: Ubuntu 20.04, mono version
Logs in the comment below (I could not put more than 2 links)

Link to logs:

It’s been a while since we updated our openPDC and openHistorian builds for mono. We will need allocate some time for this. The Linux deployments are currently just for academic purposes as we are not aware of anyone running these in production yet.


I understand, the project we are working on is research oriented too, not production.

Thanks for the reply.