openHistorian Web Manager Not Loading?


#1

After installing openHistorian and going through the set up process, the webpage for the web manager pops up. However, after a second, the web manager fails to connect. I have uninstalled and reinstalled the program, but it keeps doing the same thing. Like in the YouTube video on how to install, I keep all the defaults and I choose SQLite for my database. Any idea on what is going on?


#2

Sometimes on slower machines it can take a minute or two for everything to launch - have you tried again after letting the system sit for a minute?

If it never loads, we should check the logs to see what’s up…


#3

I’m running on a 2018 Dell XPS 15 5970 laptop, so I assume it should be plenty fast. I have waited before launching and I’m still not getting anything.


#4

Based on your description, it sounds to me like your browser is failing to make a SignalR connection to the web server. You can try using the developer console in your browser to see if there are any JavaScript errors when you refresh the page. Also, have you tried using a different browser?


#5

By default, I use FireFox. As mentioned, it didn’t load. I also used Microsoft Edge and Internet Explorer. Still doesn’t load. I’ve not used the developer console before, so I can’t tell what is normal or a problem. However, I can send screenshots if that would help.


#6

I normally use Google Chrome, and it has the best developer console. I don’t use FireFox so I guess Internet Explorer will have to be our common ground.

  • In Internet Explorer, press F12 to open the developer tools.
  • In the developer tools pane that pops up, switch to the Network tab.
  • If you see a button with a large green triangle near the top left corner of the developer tools pane, click on that button. If instead you see a red square, you don’t need to do anything.
  • Refresh the webpage and wait for the connection failure.
  • Take screenshots of both the Console tab and the Network tab. Be sure to include in your screenshots any log entries that look like errors.

#7

This is what happened.

console network


#8

Okay, that’s worse than I imagined. I thought it was just SignalR that wasn’t connecting, but I guess the whole web server is down. Is the openHistorian service still running? You can check that using the Windows Services Manager.


#9

Seems to be from what I can tell.taskmanager


#10

Alright, then we’ll need to check the logs to see if any errors occurred that might tell us what caused the web server to crash. Ideally, you’ll want to delete the existing logs and then do just enough activity to reproduce the error before you grab a copy of the logs.

  • Stop the openHistorian service.
  • Navigate to the installation folder (C:\Program Files\openHistorian) and delete StatusLog.txt and ErrorLog.txt.
  • Start the openHistorian service.
  • Wait about 30 seconds to let the system settle (this helps ensure the log messages we’re looking for don’t get drowned out).
  • Navigate to the homepage to cause the web server to crash.
  • Wait about 5 seconds (this helps ensure the log messages get flushed to the log files).
  • Get a copy of the ErrorLog.txt and StatusLog.txt files and look for errors.

You can zip those two files up and upload them here if you want me to take a look.


#11

I received an error saying that because I’m a new user, I can’t upload files. Is there a way to get around that or should I just look for something specific in the files?


#12

I thought trust level 1 would be enough, but perhaps not. I just bumped you up to trust level 3. Can you upload files now?


#13

Here you go!

Logs.zip (6.2 KB)


#14

Looks like it’s a permissions issue. If the service is running as NT SERVICE\openHistorian, then you simply need to run the following command in an admin command prompt.

netsh http add urlacl http://+:8180/ user="NT SERVICE\openHistorian"

If the service is running as a different user, you can adjust this command to apply permissions to the appropriate user.


#15

Command promt tells me this.
“Url reservation add failed, Error: 183
Cannot create a file when that file already exists.”


#16

You can display the current URL reservation with the following command.

netsh http show urlacl http://+:8180/

Here’s what mine looks like

URL Reservations:
-----------------

    Reserved URL            : http://+:8180/
        User: NT SERVICE\openHistorian
            Listen: Yes
            Delegate: No
            SDDL: D:(A;;GX;;;S-1-5-80-2554946697-3599904526-2326482286-1693768707-2441881364)

If you feel that the current reservation is unnecessary, you can remove the reservation with the following command.

netsh http delete urlacl http://+:8180/

After that you can add the reservation for NT SERVICE\openHistorian using the command I showed you earlier.


If, instead, you feel like you cannot remove the current reservation, then you will have to change the port that the openHistorian service binds for the web manager. That can be done by modifying the WebHostURL setting in the openHistorian.exe.config file which can be found in the openHistorian installation directory. Tweak the command I previously provided to apply permissions to the appropriate port. You will need to restart the service after modifying the openHistorian.exe.config file.


#17

When I do the show command, this is what comes up,

URL Reservations:

Reserved URL            : http://+:8180/ 
    User: BUILTIN\BUILTIN
        Listen: Yes
        Delegate: No
        SDDL: D:(A;;GX;;;S-1-5-32) 

Is this another program? Would that be why I can’t get the web service to work?


#18

BUILTIN\BUILTIN is pretty abnormal. BUILTIN is a valid domain, and the S-1-5-32 SID is the prefix for groups that exist within that domain, but I don’t think it’s possible to create a user or group within that domain, and I’d definitely wager that it wouldn’t be possible for any user or group to have that SID. That urlacl entry was almost certainly added in error, though I don’t really know who might have done that and why. It should be safe to delete it.


#19

Would it be easier to reassign openHistorian to another port? I checked 8179 and it was empty.


#20

It should be a pretty easy fix either way so I will leave it to you to decide. Just know that the openHistorian Web Manager start menu shortcut is set up to navigate to http://localhost:8180 by default. If you change the port, you would also need to update that shortcut or else it will take you to the wrong URL.