No connection could be made because the target machine actively refused it

I got a PSL microPMU device. After exploring the PMUConnectionTester, I ran into a problem that I tried for a while to solve but failed. Does anyone know how to solve it by any chance?

The error showed up when I clicked the connect button of the PMUConnectionTester. The attachment shows what the error said.

I am sure the IP address of the device and the device port are correct. I even tried disabling the firewall flag in the Security_settings section of the setup.ini file.

My laptop has connected the PMU device via a network cable, and they are in the same LAN.

You are trying to connect with TCP but the microPMU config settings say UDP, try switching to TCP.

1 Like

Thanks for your reply. Sorry for not showing the full name of that, which is set communications protocol for PDC . I am not sure if changing that would work. But I will try tomorrow.

That was the problem
Thank you so much! It works now!

1 Like