Installation of openPDC on Ubuntu fails

I’ve tried to install openPDC on Ubuntu 16.04. I installed the required mono, and succeeded with compiling the openPDC, and with running the following command:

sudo mono openPDC.exe -RunAsConsole

However, any connection from openPDCConsole.exe (or any other client), whether it is run on the same machine or remotely, causes the openPDC.exe process to trow the following error and refuse connection:

Error occurred while connecting client to remoting server - Unable to accept connection to client []: Object reference not set to an instance of an object

Error occurred while logging an error - Object reference not set to an instance of an object

Anyone seen that behavior before?

Any help would be appreciated!

Do you know what version you installed? For example, last release or nightly build?

Version 2.1.

I have tried to install version 2.4, however, it failed as it required .Net 4.6, while the current mono distribution provides at most .Net 4.5

The same errors here.
I also tried to run as daemon. The error said: mono[1258]: the openPDC attempted to access a path that is not on the disk.