I can not connet througth PMU connection tester neither OpenPDC


I am generating a PMU with RT-LAB and i checked in mi pc with wireshark and it show me the synchrophasors but i can not connet with PMU connection tester or OpenPDC.

In RT-LAB the PMU has, porte 4712, Device ID Code: 1
Protocol IEEE C37.118.2-2011

These are the configurarions in PMU connection tester

It show me connected but does not show me the signals

I am using PMU connection tester verion 4.6.7 i found in a discussion topic

Have you tried switching to version 2005 of the protocol?

FYI, I have found that not many implementations properly support using Config Frame 3 with version 2011 of the IEEE C37.118. If you are sure about version 2011 with Config Frame 3, I recommend the version 4.6.9 of the connection tester:

Also, double check all your connection settings, e.g., make sure no alternate command channel is defined on the connection tester, you are using IPv4, etc.

Hope that helps.


I tried with an old version (4.5.7) and i got data with PMU connection tester, but when i tried with OpenPDC o OpenHistorian neither of them does not work.

The openPDC and openHistorian use the same code as PMU Connection Tester, so if you can connect with one, you can almost surely connect with the other.

Perhaps the issue you are seeing in openPDC and/or openHistorian is another type of issue, e.g., configuration?


It show me this error:


and then show me this:


Since you are able to connect with the connection tester, you can use its configuration to setup the openPDC. While connected to your device in the PMU Connection Tester, click on File > Connection > Save, then enter a file name.

Now open the openPDC Manager UI and click on the Input Device Wizard button on the home screen.

On the first row labeled Connection File click on the folder icon (far right) and select the connection file you just saved with the PMU Connection Tester.

Take a moment to verify the details it loads, e.g., the IP, protocol, device ID, etc., then click the Next button (bottom right).

Now, importantly, make sure the PMU Connection Tester is no longer connected to the device - as some PMU connections only support a single active connection - then click the Request Configuration button (top left).

This should pick up the config frame same as connection tester, if it does, you can Next through the rest of the configuration. If it does not, something else must be askew.


When i tried with PMU version 4.6.9 you sent me, this one does not work. Review the RT-LAB documentation i verified tha i am sendidn C37.118-2011 as you can see:

I do not know why sometimes i can connected with the PMU and sometimes this connection is impossible, currently i can not connected again.

Before that i did all steps you worte but it does not works.

I do not have access to an RT-LAB simulator, so I don’t know if I can be much help with that. I can say with very high confidence that all these tools work very well with a large variety of commodity PMU hardware. We help support utilities everyday that cumulatively successfully connect and collect data from many thousands of devices.

If you are simply trying to setup a virtual PMU, you can use this tool:


It’s fairly easy to use and reliable.


I note in the documentation snapshot you provided that the RT-LAB states that some features are not actually supported. As such, I will recommend again trying to switch to the IEEE C37.118-2005 version of the protocol. Note that version 2011 is generally compatible with version 2005. The 2011 version just adds new features, like the Config Frame 3 - which again, not all protocol implementations actually handle this properly.

Just select the 2005 protocol version in the PMU Connection Tester / openPDC.

It might help.



Currently i always can connect my RT-LAB model with PMU connection tester version 4.5.7, but i have the same problema, when i tried in OpenHistorian or OpenPDC, both ways importing the connection file and also configuration file and with the wizard option but i can not stablish connection.

I guarantee only one instance is runnig (OpenPDC or OpenHistorian)

Do you have some idea what can i do to solve this?

I tried with 2005 but it does not work, i was looking for how to change the standard in RT-LAB but it is not possible, but in the documentation limitations does not show something about the connection

The C37.118 communication protocol has been implemented according to the IEEE Std C37.118.2-2011 standard. However, some features are not supported for the moment. Please refer to the Limitations section for more information.
Three communication protocols are supported: TCP only, UDP only or TCP/UDP. It is the user’s responsibility to select the communication protocol that matches their requirements.
More details can be found in Annex F of the IEEE Std C37.118-2-2011 document.
The following is a list of the limitations of the driver:
• It operates asynchronously from the model simulation step. It will try to receive data as fast as possible and provide it to the simulation.
• It needs to be configured manually by knowing in advance how the PMU is configured (see above).
• It cannot receive PMU configuration frame 3 (CFG-3).
• It cannot receive encrypted data (SSL).

Thank you Ritchie for you reply.

I was checking the issue with OPAL and effectively the problem was in the standard C37.118-2011, this one does not support the frame3 so it reject the connection, however you can use the standard C37.118-2005 to connect with the models.