Grafana with Phasor Map plugin

Hi Team,

We are trying to incorporate Phasor Map plugin with openHistorian Web Interface/Grafana.
I followed instruction and able to load the plugin in openHistorian Grafana interface.
But I’m not able to set the value or see any properties related to positions in edit page.

Elements or Function was not in selectable/editable sate.

I’m using openHistorian server Manager
This is the customized version, If we need to include as part of this product, what are the changes required.
Whereas we tried with openHistoiran 2.7.x, we were able to set the value.

Please clarify.

Thanks & Regards

Have you tried simply updating the Grafana phasor-map plugin to match latest version?

Version 2.6.30 of the openHistorian did not include the Phasor Map Plugin. The newest version of the Phasor Map Plugin will most likely not help you in this case. Since we technically did not write the Phasor plugin until Version 2.7.60 of the openHistorian there might be some issues with older versions.
You can try the following things:

However note that none of these are guaranteed to work. Unfortunately the changes made to get the Phasor Panel running are complex and span multiple commits and projects. In addition we have also updated Grafana a few times since 2.6.30 was released (most recently in 2.7.154) which can also affect the Phasor Map Panel.

It is pretty much impossible to give you a list of the changes required to make this work due to the large number of changes since 2.6.30. I recommend trying to upgrade to 2.7.X or 2.8.X.

Hi Clarkner,

Thanks for your quick response.