Error Attempt to write a readonly database


I got this error when I try to create a new measurement in openECA:
“Exception has been thrown by the target of an invocation. Inner Exception: attempt to write a readonly database”

This error occurs after I restart my openECA. This problem can be solved by re-running “Configuration Setup Utility” to reconfigure my database. However, it will loose all the saved measurement information. Is there any other ways that I can solve this problem without re-running the configuration?

Thank you so much!

Hi Tong,

Can you be a little more specific? Are you using the openECA Manager to create a new measurement on the openECA server through the Metadata > Measurements screen? Depending on where you placed the SQLite database on your filesystem, you may need to change permissions on the folder that contains the database file or run the openECA Manager as administrator in order to write to the database.


Hi Stephen,

Thanks for your reply. It works when I run it as administrator.