Disconnected from TCP ://localhost 8500

I have a trouble and need your help. When running the program, the result of the openPDCconsole run is “disconnected from tcp://localhost :8500, Enter the credentials to be used for authentication with the service”
then ,it request input user name and password. I tried it many times and it has been unsuccessful. Which username and password is this?,thanks!

Is the service running? Open Windows Services and scroll down to openPDC and much sure it is running. If not start it and try again. If it is running, you may not have access to the openPDC or the database has not been configured properly.

If this is a new instance, you can always re-run the Configuration Setup Utility to create a new database.


when I run the openPDCManager , Such a pop-up window appears as shown below.


Where is the problem?


Looks like the wrong NodeID is selected for the database - the soultion is to re-run the Configuration Setup Utility and connect to your database.

When I opened the source code with VS16, I found that the project file (openPDC)was uninstalled and openPDCSetup is not compatible.and the following error was reported when running the program.

This is where the problem occurred.
thank you

The configuration file for that program likely has an encrypted setting in its configuration file for which the system has lost the encryption key and is therefore unable to decrypt it. You will need to restore the default configuration or fix that configuration setting manually.

thanks for your help,
However,how should I restore the default settings, what should I do?
thanks a lot

First, look for the file openPDCConsole.exe.config. Open that in your favorite text editor, such as Notepad, and look for a setting with encrypted="true". If you can find one, you will need to set encrypted to false and change it to its default value.

If you can’t find any settings in openPDCConsole.exe.config, you may need to look for the user settings file located in AppData. Navigate to %appdata%\Grid Protection Alliance\openPDCConsole and find the file called Settings.xml. If it’s there, all you should need to do is delete it.

thanks for your help,
I have set encrypted to false and changed it to the default value.
Then I run the code again, the program reports the following error, what is the username and password?


That would be whatever username and password you entered when you ran the Configuration Setup Utility.


  • OR -