PhasorData for one PDC is invalid after another is added


#1

Hi,

let say we have configuration similiar to this:

  • PDC1 containing PMU-A to PMU-C
  • PDC2 containing PMU-D to PMU-F
  • PDC3 containing PMU-G to PMU-J

All PDCs contains only PhasorData.

If we create new OutputStream containing only PDC1 or PDC2 or PDC3, everything works
If we create new OutputStream containig PDC2 and PDC3, everything works too.
But if we create new OutputStream containing PDC1 and PDC2/3, PDC2/3 has data but PDC1 shows (in Connection Tester) IsDataValid:false;

We tryied different combinations of PMU in streams, we recreated input streams, we tryied it on another openPdc machine. Nothing helps.

Do you have any idea what we should focus on?

Thanks in advance, Lukas


#2

Hi Lukas,

I recently answered a similar question on GitHub, and you may find the answer relevant to your issue.

In your case, however, it seems like the cause for missing data in your output stream is the mixture of PDC1’s data with PDC2’s or PDC3’s data. Normally, it wouldn’t make a difference to PDC1 if PDC2 or PDC3 were included in its output stream, but it does depend on your output stream’s configuration. I would suggest comparing the timestamps of the data coming from PDC1 with the timestamps of the data coming from PDC2 and PDC3. The default lag time is 3 seconds, so if the timestamps are off by more than just a couple seconds, then they probably can’t be sorted in the same frames.

Thanks,
Stephen


#3

Hi,

we tryied described workaround using connection string, but without success.

Finally we discovered, that the main reason why are all streams from one PDC has IsDataValid=false is due to one of PMU’s in this PDC was off (due to reconstruction in station). When PMU came online, problem disappears.

Do you have any idea now?:slight_smile:

Thanks,
Lukas


#4

Hi Lukas,

Yes, if the output stream does not receive all the data it expects to receive from a particular data source, it sets the IsDataValid flag for the corresponding data cell to false. This behavior is by design, though it is possible to change the behavior.

Thanks,
Stephen