GEP Data Extractor : add a parameter to specify the .csv separator character


Edit 01/27/2023 : even if I change the separator character manuely from ‘,’ to ‘;’ I may have a problem with the decimal separator that must be ‘.’ instead of ‘,’ in my regional settings. So It may not solve the whole problem to only change this character separator in the extraction file. I put the following change request in ‘pause’ mode in order to investigate more further the issue I encounter …

I’am trying to use GEP Data Extractor to export some historized data from openHistorian .d2 files. Users have it on their own PC (juste pasting the requiered exe/config/dll files on it) because I don’t want them to access to the whole openHistorian server for security reasons. Unfortunately in GEP Data Extractor the default field seperator character in the csv output is the comma, as for the ‘by default’ regional setting for the decimal separator in my country. The result is an unexploitable csv file containing commas used as a dot decimal separator and fields separator. Because the users PCs are off course also used for other work stuff ; I can’t ask them to modify the regional parameters to change this. A solution would be to allow the user to specify of the desired separator character in the CSV at the GEP Data Extractor interface.

Do you think that this improvement would be possible ? Or maybe do you have another way to workaround this problem ?

We would like to use these files as input data sources for some of our analysis applications

Thank you very much,