C37.118-2011 : unable to import XML Config File from PMU connection tester

Hello,
I have two servers both running OpenPDC 2.9.8.0.
Server A is sending 12 PMUs data to server B through a concentrator output stream (configured with the new IEEE C37.118-2011 option added in 2.9 version of OpenPDC).
Server B is received the 12 PMU data on a Concentrator device and 12 related devices.
This configuration has been made before upgrading to the 2.9.8 version, when only C37.118-2005 version of the protocol was available in the list for the output stream ; and it still working after changing it to -2011 version.

I recently added a 13rd PMU to Server A, then added it in the list of devices of the output concentrator stream. I then saved and initialized the output stream, expecting this new device to be automatically detected and added in Server B ; but it was not the case (even after ‘initialize’ the concentratror device on server B).

I then try to test the stream with PMU connection tester on server B (configured with C37.118-2011 protocol) and it works fine : I can see this 13rd PMU in the list and the phasors data related to it. I then create the .xml connection and config files in order to import them in the Server B OpenPDC ; using the Input Device Wizard. On step 1 I can specify the connection file and the C37.118-2011 protocol ; then going to the step 2. When I specify the Configuration File, I have the following error :
image

This error is still poping when I choose C37.118-2005 in the step 1 of the process.
Using the two .xml files in PMU connection tester (with the ‘File > Connection > Load’ and ‘File > Config File > Load’ menus is working fine).

So there seem to be two problems:
The addition of a new PMU in an output stream is not automatically taken over in the OpenPDc which uses this stream; and it no longer seems possible to add new PMUs via the device Wizard.

Using the walk-through process doesn’t work either : the requesting configuration process is going and going on ; then showing the following error message :
“ERROR : Response timeout occurred. Waited 60 seconds for Configuration Frame to arrive.”

Are you seeing the same problem? Is there one or more solutions to correct / work around the problem?

Thanks by advance for any help you could provide,

Regards,

Perhaps the version of PMU Connection Tester you are using is not compatible with the latest version of openPDC. It appears to me that you should probably be using v4.6.1+ of the PMU Connection Tester. It looks like Ritchie posted a v4.6 release candidate which will install v4.6.2. You can find it here.

I have a found a few issues with the release candidate, I am posting some changes in a few hours and will provide a download link today…

I have checked in several fixes for IEEE C37.118-2011 imports, if you would like to try the latest build:
https://gridprotectionalliance.org/NightlyBuilds/openPDC/Beta/Synchrophasor.Installs.zip

Hello,
Thank you for your quick replies.

I’ve updated PMU Connection Tester with the 4.6.2 version (I was on 4.5.5), then generate new .pmuCapture and .xml configuration files. The .pmuCapture is strictly the same as the previous one ; but the .xml introduce several significant changes.
I then tried to import those new files in the 2.9.8.0 to test it and it failed with a new error : “Index was outside the bound of the array”.
I then updated OpenPDC to the 2.9.14.0 and tried again : everything solved. I was able to import the new PMU to the database.

Once again, thank you very much for your responsiveness and efficiency in solving this problem.

Regards

Thanks so much for your testing! We will publish a new release candidate next week.

Hello !
I am ‘upping’ this topic because the problem is back again with the 2.9.43 version of OpenPDC : I can’t import an .xml file made with PMU connection Tester due to the following error :
image

PMU Connection Tester version is : 4.6.3. I’m using it to generate the .pmucapture and .xml files in order to import some devices (one PDC and related PMUs) from server A to B.
OpenPDC version which send the data (Server A) is 2.9.43
OpenPDC version where I’m trying to import the devices (Server B) is 2.9.43
I’m using IEEE C37.118-2011 protocol.

Using the wizard to make the import isn’t working either : the ‘Requesting configuration’ window is going on and then show the following error message :
image

I know that the stream is working well because I can see it in PMU Connection Capture.

Any help would be appreciate !

Thanks !

Regards !

Try switching to C37.118-2005 - the 2011 version attempts a Config 3 Frame.

Also, can you provide a copy a copy of the .XML file you are using - I will try to replicate your issue…

Hello !

I’ve tried with the 2005 version and have the following error :
image

I sent Ritchie the two xml files (for 2005 and 2011). Hope you can replicate and fix the issue !

Regards.

Interestingly both XML configuration files are working fine for me no matter which protocol I pick.

Can you verify the version of your openPDC?

Hello,

Sorry for the delay. I’ve made several tries and finally found what was wrong with my configuration.
I was trying to add a new stream (with the 14 PMU) in an OpenPDC that already have a concentrator with the same PMU designation (names/acronyms), coming from another server :

  • SERVER_C is the main PDC, that have a concentrator containing the 14 PMU from SERVER_A ; and in which I try to add a second stream/concentrator containing the same 14 PMU from SERVER_B.
  • SERVER_A sending the 14 PMU data at a 50 fps framerate.
  • SERVER_B sending the 14 PMU data at a 10 fps framerate.
    SERVER_C is running an oscillation analysis module on both group of PMU in order to study the relevance level of the results based on the input framerate.

I finally managed to integrate the second stream by previously renaming the acronyms of the 14 PMUs of the first stream already in the OpenPDC of server_C (adding the ‘_50_FPS’ suffix).

In conclusion, trying to add a stream with the ‘add device Wizad’ which contains (at least one ?) device(s) with an acronym that already exist in the database generates the error message.

Anyway, thank you very much for your answers that helped me to understand that the issue was coming from my configuration and not from the OpenPDC product.

Regards.

Edit : I finally achieved my goals with the 2011 version of the protocol. I imagine the result would be identical with the 2005 version.

1 Like