Transmit Data to pmu connection tester through networking


#88

Sir,
I have tried by unchecking the box of “Enable Multicast / Remote Udp”.

It’s not working sir.


#89

I don’t know what else to tell you. The same exact setup works fine for me.

Are you running openPDC and PMU Connection Tester on the same system?

Thanks,
Stephen


#90

yes sir
I am running open pdc and pmu connection tester on same system.
What can be the problem sir? Please help me


#91

Either the data is not streaming from the source device or the openPDC is not streaming data to localhost:4712. Beyond that, I’m not sure what could be wrong.

Thanks,
Stephen


#92

Sir what will i do now?
Why open pdc is not streaming or data is not streaming from the source ? What can be the reason? Please help me ! This is important part of my project.


#93

Start investigating. You have to figure out why your data isn’t streaming. For instance, does the data show up on the Graph Measurements screen in the openPDC Manager? Can you maybe do away with the UDP channel in openPDC and use the TCP channel for data?


#94

Yes sir ! Data is shown on graph measurement screen.
I can’t understand what you say about tcp and udp? Please guide me!


#95

Steven is saying you can simplify your connection by only using TCP and not using UDP. In this case only fill out information in the openPDC Manager for TCP - the UDP settings should be blank. In the PMU Connection Tester, you should also only be on the TCP tab - with no alternate command channel defined. Also, always make sure to “re-initialize” your output stream after any configuration changes so the changes will take effect.

This is the simplest possible connection.

Now, if you still have no data, then the timestamps in your data are being discarded. Cause being that the timestamps are outside of range of the local clock according to your lead-time setting. To completely ignore bad timestamps you can unselect the “Perform Timestamp Reasonability Check”.

If you still see no data - make sure you can actually see data in the openPDC Manager under “Graph Measurements”…

Thanks,
Ritchie


#96

By the way, as a courtesy to those are trying to help you, it is considered not polite to end your sentences with an exclamation point. When read, statements ending with an exclamation point are generally considered as yelling and/or demanding and over all considered rude. I assume English is not your first language so we have been ignoring your punctuation and emphasis, but I assure you, it is not required to get a more timely response. As with any one who posts a question, we will answer as quickly as we can given all our other duties.

Thanks so much and good luck with your project…


#97

I apologise ritchie and steven sir for my bad english. I haven’t meant to yell or demand. I am only requesting and you helped me alot in this project and i am greatful to you. Sorry sir


#98

Sir,
I have tried this before. I only filled tcp tab without alternate channel. But results are same. I uncheck reasonability check option but data is not streaming.


#99

Try removing the connection string under “UDP Channel” in the openPDC Manager. Remember to Save and Initialize the output stream, in that order.

Thanks,
Stephen


#100

Sir,
I have done same to same thing as you say but results are same.


#101

Then, as Ritchie suggested, your data is probably being discarded by the concentrator. Try updating this setting. You may be tired of me saying it, but remember to Save and Initialize the output stream, in that order.

Connection String: processByReceivedTimestamp=true


#102

Sir,
Why my data is being discarded?
Is there any solution for it?


#103

Sir,
Updation of Connection string setting works. I have got my output.
Thank you so much sir.


#104

The data is discarded by the concentrator if the timestamp of the data is more than 3 seconds old. The connection string setting that I suggested is designed to completely disable that validation to allow for concentration of historic data. You may want to check the PMU Connection Tester output to make sure the timestamps match what you were expecting.


#105

Okay sir. I will check that.


#106

Sir,
Is this possible that Concentrated data created by openpdc manager export to network ?
If possible then what is procedure ?
What will be the format of concentrated data?


#107

The output stream you set up is already sending its data over the network. The procedure is the same except that you need to run the PMU Connection Tester from another system on the network. The format will depend on the “Type” parameter you select on the Output Streams page of the openPDC Manager.