Open Historian - Web Service does not run automatically


Outlined below is my problem and my work around. There has to be a better way so if you know of one please speak up.

I installed open historian 2 just fine and was able to use a web browser connected to ‘localhost:8180’ just fine. After I restarted my computer I could not successfully navigate to ‘localhost:8180’. I tried launching all the applications under start–> OpenHistorian but nothing enabled me to browse ‘localhost:8180’

Here is my fix.

Start menu --> OpenHistorian --> Configuration Setup Utility

Select ‘I want to use an existing configuration’

Select 'Database’
Select 'Use existing database as is’
Select 'MySQL’
Credentials should already be entered in
Make the following selection

Continue to follow prompts and finish.
Now the web manager works. My question is this, what is hosting the web service and how to I start it manually and how do I start it automatically.

openHistorian 2.0 Utilities

This should start automatically - what version are you installing?


I know this reply is way overdo but the version is 2.4.22


If you go to the Services control panel in Windows - let’s check to make sure openHistorian is marked to start automatically.

To do this go to “Control Panel > Administrative Tools > Services”, then scroll down the the alphabetically sorted list until you find openHistorian. Once located, right-click on the entry and select properties - then make sure “Startup Type” is set to automatic.



I verified and it was already set to “Automatic”.

Also for anyone else reading I wanted to note that the on the list of services there are two tabs at the bottom. “extended” and “standard”. Select “standard” tab in order to find openHistorian.

I’m not sure if it matters but there is a column “Log on As”… mine is set to NTService\openHistorian


That’s the correct login ID - that’s the local system service account for openHistorian.

I suppose one possibility is that the openHistorian is trying to start too fast (i.e., some dependent operating system functions are not yet available).

Try setting startup type to “Automatic (Delayed Start)” and rebooting.



That appeared to work!